InsideDarkWeb.com

GRUB not responding to keyboard

I installed Ubuntu 12.4LTS on dual boot with Windows XP on my 7 year old desktop PC 2 months ago.
Everything worked perfectly in both Ubuntu and XP until last week when I removed LibreOffice from Ubuntu and installed OpenOffice 4.0.1. (removal/installation done from Terminal as per Ubuntu online instructions).
At the GRUB menu window, the keyboard is now inoperative, so the system times out and boots Ubuntu (which still works perfectly) but I cannot boot XP.
The keyboard (USB) works perfectly at the BIOS stage of startup, does not work during GRUB, but works again from the Ubuntu login onwards.
I have looked through the Q&As for a solution, the nearest refers to BIOS keyboard setup, but as my keyboard works in BIOS I don’t think this is the cause.
I am not sure where the problem might be. I have looked at grub.cfg, and whilst a newcomer to Linux, cannot see anything obviously corrupt, although I cannot identify which method/module/function call (if any) reads the keyboard.
I was considering reloading GRUB, but if the problem is elsewhere this won’t solve it, and might make matters worse.
Any advice would be much appreciated.

Ask Ubuntu Asked by BrianW on November 21, 2021

17 Answers

17 Answers

In my case (Dell XPS 15 9550 with latest BIOS/UEFI 1.14.0) was because I added a USB-C dongle between the keyboard and the laptop.

Answered by morhook on November 21, 2021

I would like to second what Pablo Bianchi said. Even though USB Legacy boot =>[ENABLE] it had the problem with grub menu. changing it to USB Legacy boot =>[AUTO] solved the issue.

Answered by user103720 on November 21, 2021

I realise this is quite an old post, but I have had the same problem with a clean install of Ubuntu 20.04 and Windows 10.

I found that grub would not respond to my keyboard when connected to a USB3 port, but works fine with legacy USB2.

Answered by MrPaulDriver on November 21, 2021

If "fast boot" is causing the problem but you don't want to turn it off, change "USB Support" from "Partial Initial" to "Full Initial" in the BIOS if there is such an option (at least at my GIGABYTE BIOS). This activates all USB devices before OS boot.

Answered by oxq on November 21, 2021

My USB-Keyboard Coolermaster Quickfire TK was not responding in Grub2 (or at least making strange inputs like a,e,3 were possible, but on wrong buttons). Another usb- keyboard worked fine.

My solution was to turn the Keyboard itself into 6KRO Mode instead of NKRO Mode by pressing "6" and "ESC".

Answered by Tecqu on November 21, 2021

Turn off the fast boot in the BIOS (it worked for me).

When I hover to fast boot it says something like, fast boot is for minimizing device input for making the load faster or something, so when I turn fast boot off, and save the changes and restart my laptop it works!

Answered by Arosifu on November 21, 2021

Although some time has passed and several hints about not working keyboard in grub can be found on the web, i discovered a reason which to consider may help in some cases:

The USB keyboard may be unusuable in grub because another USB device is also plugged in which interferes with grub keyboard usage.

For details in such a case please see https://savannah.gnu.org/bugs/index.php?57010

Answered by Michael on November 21, 2021

Mine was resolved by using a USB2 slot (removing from USB3 slot).

Answered by ggdx on November 21, 2021

I tried enabling and disabling the BIOS keyboard support, didn't work. (Yes, keyboard works with the BIOS but not GRUB, but does work immediately after GRUB menu using CTRL-ALT-DLT to halt the boot process). While searching I saw someone else said about trying all USB ports. I remembered that the previous week I had moved the keyboard from one USB port to another to make space for a larger USB dongle to be plugged into a nearby USB port. So I moved the keyboard back to the USB port it was in previously and it works. Apparently on this Dell SC440, only some USB ports work with GRUB.

Answered by JavaMan07 on November 21, 2021

In my case there was Keyboard and mouse disabled in BIOS. Could look for this in the future.

Answered by Alxander Vladimirov on November 21, 2021

Mine wouldn't work, In the Award Cmos Setup Utility, I changed first boot device to HDD and the other two disabled, and enabled USB keyboard and mouse, hope this helps.

Answered by Joe on November 21, 2021

I also had this problem and it turned out my mouse was somehow prohibiting the keyboard input. I unplugged it and everything worked fine.

Answered by Leo on November 21, 2021

Windows 7 and Ubuntu 14.04LTS dual boot, GRUB2 reinstalled using boot-repair, wireless USB keyboard, no keyboard recognized on GRUB2 screen resolved.

  • BIOS Setup
  • Integrated Peripherals
  • Legacy USB Support --> [Enabled]

I now have up and down arrow keys on the GRUB2 screen. NumLock is now toggled off at boot time, but NBD.

I'm not sure how to mark it RESOLVED, but since it's not a new thread, I don't think I have the power.

Answered by The DOuGTrainer on November 21, 2021

I had the same problem but none of the above helped. In my case I had to enable the BIOS option "use USB in DOS".

Answered by JaBu on November 21, 2021

In my experience, I had the boot set to "fast" which it would boot up faster, but in doing that, it didn't allow my keyboard to work in dual boot when I would turn on my laptop from shutdown. It would only work right going into ubuntu (obviously when keyboard doesn't work) and/or rebooting which brings back to dual-boot main screen setup. I loaded the default settings which set boot to "normal" and this solved it for me for those that who might be stuck and a last resort before doing a Ubuntu re-install. Hope this helps.

Answered by Wes Warriner on November 21, 2021

TL;DR. Try all your USB ports including all USB ports on your docking station if you have one.

I just experienced the same thing with a new installation of Ubuntu 14.04.2 LTS and a following dist-upgrade now running the following:

  • Ubuntu 14.04.2 LTS (lsb_release -a)
  • 3.16.0-33-generic (uname -r)
  • grub-install (GRUB) 2.02~beta2-9ubuntu1 (grub-install --version)

The keyboard worked the first times I booted to GRUB so I could boot Windows 8.1 as well but then it suddenly stopped working without any good reason I thought. Just like OP I could use my keyboard in BIOS and USB Legacy keyboard was already enabled so no luck there. Finally I found a PS/2 keyboard which worked in GRUB menu and I could stop the countdown timer. I now tested my USB keyboard in all USB ports on my laptop and in the docking station and it only works with GRUB in one USB port.

Looking back at this of course there was a good explanation. I had moved my desk just after doing my dist-upgrade and had disconnected all cables while doing the move and then reconnected the keyboard to wrong USB port.

I hope this helps.

Answered by CHolmstedt on November 21, 2021

PROBLEM SOLVED, it was BIOS related (appears BIOS screen is skipped if rebooted with 5min of shut down). Changed boot sequence from Floppy,HDD to CDROM,HDD. Rebooted with NO CD in drive (GRUB not updated),keyboard now works at GRUB screen so can access all options. Now realise that I changed backup coin cell on motherboard around time I installed OpenOffice, suspect this changed boot sequence to default and somehow affected keyboard. Have compared current & previous grub.cfg – identical. Now have boot-repair disk ready for any future issues.

Answered by BrianW on November 21, 2021

Add your own answers!

Related Questions

Ask a Question

Get help from others!

© 2021 InsideDarkWeb.com. All rights reserved.