InsideDarkWeb.com

no graphical login prompt and VM lockup after ubuntu upgrade 18.04 to 20.04

I successfully upgraded my Ubuntu 18.04 VM (Virtualbox 6.1 hosted on MacOS) to 20.04, but the gnome display manager login prompt doesn’t appear. I see the ubuntu splash screen, and then it goes black and unresponsive.

X11 worked fine before the upgrade with a default run level of 5.

I can boot with runlevel 3, and manually run startx from tty1 after that without error. If I try telinit 5, then I also see an ubuntu splash screen, then black screen. About a minute after that, any ssh sessions that I have active become unresponsive, and I also cannot tty switch back to the console with F1-6. At that point I have to powerdown the VM, and either let the fsck run or restore from a previous snapshot.

The graphics adapter, as seen in ubuntu is:

   $ lspci -nn | grep -E 'VGA|Display'
   00:02.0 VGA compatible controller [0300]: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef]

Are there any known issues that would explain this? If not, I’d appreciate some diagnostic tips.

Ask Ubuntu Asked on November 11, 2021

1 Answers

One Answer

I ran 'dmesg -w' in an ssh session while I tried 'sudo telinit 5' in the VM display, and saw the following message before the machine became unresponsive:

[ 219.138358] [drm] Error -12 pinning new fb, out of video mem?

Bumping up the video memory to 32Mb seems to handle the issue (despite the fact that vbox says that's not a valid setting.)

Answered by Peeter Joot on November 11, 2021

Add your own answers!

Related Questions

How can I install gem5?

4  Asked on December 1, 2020 by deepsidhu1313

       

Ubuntu 20.04 LTS 64-bit installation freezes

0  Asked on November 30, 2020 by dbc_xl

   

Install Ubuntu Patch to solve CVE

1  Asked on November 30, 2020 by kostas-t

 

How to install a Canon PIXMA IP 3300?

1  Asked on November 29, 2020 by niols

       

In what file does gnome-calendar store calendar events?

1  Asked on November 28, 2020 by astral-axiom

     

error installing on via motherboard C3 CPU

1  Asked on November 28, 2020 by johan-designervisuals

 

Intel(R) UHD Graphics and VLC video lagging 18.04 XPS 13

0  Asked on November 28, 2020 by junaid-farooq

     

CUDA install removes Nvidia driver in ubuntu 18.04

0  Asked on November 28, 2020 by pranto

     

Display Image, cannot reach X server

1  Asked on November 28, 2020 by guillaume

   

Main sound device disappears after resuming from sleep mode

1  Asked on November 28, 2020 by franois-requet

     

how to resolve -bash: /etc/ViewPowerPro/Console: No such file or directory at startup?

1  Asked on November 27, 2020 by carlos-andres-zapata-cuervo

   

On Ubuntu 16.04 web server, second “<?" gives an error

0  Asked on November 26, 2020 by jordi-sv

       

Ask a Question

Get help from others!

© 2021 InsideDarkWeb.com. All rights reserved.