InsideDarkWeb.com

Touchscreen stops working a few seconds after login to Gnome/Ubuntu session (Ubuntu 20.04)

I cannot manage to make my touchscreen to work properly on a fresh installation of Ubuntu 20.04. On the login screen I can still touch the screen to select the user and the password edit box. Even in the first few seconds after login to Gnome/Ubuntu desktop the touchscreen stays responsive for a few seconds but then stops working (just enough time to start a terminal..)

Informations

  • Laptop/Convertible: HP Spectre x360 13-4230ng
  • Touchscreen: SYNAPTICS Synaptics Touch Digitizer V04 (according to xinput and evtest)
  • Driver used in the xorg-server: libinput (I tried evdev, but then even the touchpad did not respond anymore, so I switched back to libinput)

To me this seems like a strange problem with the Xorg driver, but I cannot figure out what’s wrong.

Using evtest I found out that the touchscreen sends signals as long as the Xserver of the Gnome/Ubuntu session is not started yet. After that it does not send signals anymore.

The fact that I had the touchscreen working during the first session makes me quite sure that there should be a fix for this, or at least a workaround. Maybe there are some configuration files that were created during the first start of the Gnome/Ubuntu session? I tried to remove ~./config/dconf/user, but this did not help. Are there any others? Is there another Xorg driver that I could try?

Just to add some more information I append the relevant part of my Xorg.log here:

[    17.425] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 Mouse (/dev/input/event4)  
[    17.425] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: Applying InputClass "libinput pointer catchall"  
[    17.425] (II) Using input driver 'libinput' for 'SYNAPTICS Synaptics Touch Digitizer V04 Mouse'  
[    17.483] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 31 paused 0  
[    17.484] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: always reports core events  
[    17.484] (**) Option "Device" "/dev/input/event4"  
[    17.484] (**) Option "_source" "server/udev"  
[    17.487] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: is tagged by udev as: Mouse  
[    17.487] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: device is a pointer  
[    17.488] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: device removed  
[    17.488] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.0/0003:06CB:16F9.0001/input/input13/event4"  
[    17.488] (II) XINPUT: Adding extended input device "SYNAPTICS Synaptics Touch Digitizer V04 Mouse" (type: MOUSE, id 10)  
[    17.488] (**) Option "AccelerationScheme" "none"  
[    17.488] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: (accel) selected scheme none/0  
[    17.488] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: (accel) acceleration factor: 2.000  
[    17.488] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: (accel) acceleration threshold: 4  
[    17.490] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: is tagged by udev as: Mouse  
[    17.490] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: device is a pointer  
[    17.491] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 Mouse (/dev/input/mouse0)  
[    17.491] (II) No input driver specified, ignoring this device.  
[    17.491] (II) This device may have been added with another device file.  
[    17.492] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 (/dev/input/event5)  
[    17.492] (**) SYNAPTICS Synaptics Touch Digitizer V04: Applying InputClass "libinput touchscreen catchall"  
[    17.492] (II) Using input driver 'libinput' for 'SYNAPTICS Synaptics Touch Digitizer V04'  
[    17.493] (II) systemd-logind: got fd for /dev/input/event5 13:69 fd 32 paused 0  
[    17.493] (**) SYNAPTICS Synaptics Touch Digitizer V04: always reports core events  
[    17.493] (**) Option "Device" "/dev/input/event5"  
[    17.493] (**) Option "_source" "server/udev"  
[    17.496] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: is tagged by udev as: Touchscreen  
[    17.496] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: device is a touch device  
[    17.496] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: device removed  
[    17.496] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.0/0003:06CB:16F9.0001/input/input14/event5"  
[    17.496] (II) XINPUT: Adding extended input device "SYNAPTICS Synaptics Touch Digitizer V04" (type: TOUCHSCREEN, id 11)  
[    17.496] (**) Option "AccelerationScheme" "none"  
[    17.496] (**) SYNAPTICS Synaptics Touch Digitizer V04: (accel) selected scheme none/0  
[    17.496] (**) SYNAPTICS Synaptics Touch Digitizer V04: (accel) acceleration factor: 2.000  
[    17.497] (**) SYNAPTICS Synaptics Touch Digitizer V04: (accel) acceleration threshold: 4  
[    17.499] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: is tagged by udev as: Touchscreen  
[    17.499] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: device is a touch device  
[    17.500] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 (/dev/input/mouse1)  
[    17.500] (II) No input driver specified, ignoring this device.  
[    17.500] (II) This device may have been added with another device file.  

Ask Ubuntu Asked by xeliba on November 14, 2021

3 Answers

3 Answers

I had the same problem with my Lenovo Yoga S1.

I noticed in journalctl -b:

systemd[1]: Starting Firmware update daemon...
fwupd[2737]: ERROR:esys:src/tss2-esys/esys_context.c:69:Esys_Initialize() Initialize default tcti. ErrorCode (0x000a000a)
fwupd[2737]: 21:37:44:0499 FuEngine failed to add udev device /sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/0003:06CB:7244.0003/>
fwupd[2737]: 21:37:44:0675 FuEngine device 602b0a6cc821d155208724f0e22f8d111542b74c [SAMSUNG MZ7TE128HMGR-000L1] does not define a vendo>
systemd[1]: Started Firmware update daemon.

I noticed 06CB:7244 is:

$ lsusb
Bus 001 Device 006: ID 06cb:7244 Synaptics, Inc. Synaptics Touch Digitizer V04

I tried blacklisting plugin synaptics-rmi in /etc/fwupd/daemon.conf:

BlacklistPlugins=synaptics-rmi;test;invalid

But it did not help. In the end I did:

sudo apt remove fwupd

I guess that's not the best way to solve the problem but it worked!

Answered by wojt on November 14, 2021

Looks like it's this bug: https://bugs.launchpad.net/bugs/1876991

Marking it as affecting you too will increase chances it will be noticed. Also you can subscribe for updates there.

If your touchpad is set to be disabled with mouse you can try these settings:

GNOME: gsettings set org.gnome.desktop.peripherals.touchpad send-events enabled command, Details: How do I disable touchpad when using a mouse

KDE: System Settings > Input Devices > Touchpad > Enable/Disable > Ignored Devices > Add your "mouse" touchpad/touchscreen entry, should be already filled in as it's "connected".

Answered by int_ua on November 14, 2021

Sorry I'm quite new here an can't comment on your post yet as it's not unlocked yet.

But i face the very similiar issue with Ubuntu 20.04 and Gnome 3.36.1 with the HP spectre x360 13-4203ng in my case.

I welcome any kind of help or idea or request to debug and find the issue, as i'd really like to have the touchscreen working again.

Thanks for all your support - Jack

Answered by JacknJo on November 14, 2021

Add your own answers!

Related Questions

AMD Radeon R5 M330 error trying to use DRI_PRIME=1

0  Asked on January 29, 2021 by kevin-joshua

     

Unexpected SPC Access Width error returning to default e

0  Asked on January 28, 2021 by christophe-naud

     

Stream a recoreded Video to youtube

1  Asked on January 28, 2021 by ton-gok

     

Disable a Multimedia Key on Keyboard

0  Asked on January 28, 2021 by hell_storm2004

       

RE: Modifying bluetooth scan parameters via btmgmt

0  Asked on January 28, 2021 by mario-palumbo

   

Can I install latte dock in gnome DE?

1  Asked on January 28, 2021 by arjun-vk

     

WiFi isn’t being detected on Lubuntu 18.04

0  Asked on January 28, 2021 by cappuccino

         

Jupyter Notebook Installation

6  Asked on January 27, 2021 by karfai

         

Unable to add online accounts in the gnome control centre

0  Asked on January 27, 2021 by hoda-asif123

     

None of subtitle editors show video

1  Asked on January 27, 2021 by alex-wolf

       

Ubuntu menu won’t close after opening

0  Asked on January 27, 2021 by shadowblitz16

   

Ask a Question

Get help from others!

© 2021 InsideDarkWeb.com. All rights reserved.